DEVELOPMENT

파이참(PyCharm), 파이썬 인터프리터(Python Interpreter) 설정 방법

개발자 간지뽕빨리턴씨 2021. 5. 7. 07:26
반응형

파이썬,jetbrain,파이참,아나콘다,IDE,개발툴,프로그래밍,실행오류,인터프리터,개발언어,젯브레인

  PyCharm :: Interpreter Error 해결 방법

파이참이라는 프로그램을 이용하면서 사소하지만 초반에 잘 몰라 실수했던 부분을 여러분들에게 해결할 수 있는 방법을 공유하고 싶어서 해결방법을 정리했습니다 아래와 같은 방법으로 진행을 해주시면 해결이 됩니다.

 

파이썬 개발환경으로 많이 이용하고 계시는 파이참(PyCharm) 처음 설치 후 간단한 Hello World!를 실행을 하려고 하면 뜨는 오류가 있다 바로 아래와 같은 문구가 나옵니다.

Error: Please select a valid Python interpreter

위 오류는 올바른 파이썬 인터프리터를 이용하라는 것으로 간단하게 설정만 해주시면 해결할 수 있습니다. 아래와 같이 차근차근 따라오시면 됩니다.

파이참 화면에서 상단 오른쪽 부분에 톱니바퀴 모양을 누른 후 Settings(Ctrl+Alt+S) 클릭합니다.

Settings 화면에서 Project: Project 메뉴에서 Python Interpreter로 이동합니다. 위와 같은 화면으로 이동이 되는 것을 알 수 있습니다.

오른쪽 상단에 톱니바퀴 모양을 누르고 Add..를 누릅니다.

Add Python Interpreter화면에서 Pipenv Environment를 누른 후 Base interpreter를 클릭 후 파이썬 버전을 선택하시면 됩니다.

그리고, 다시 Settings로 나오게 되면 해당 화면과 같이 Python Interpreter에 파이썬 버전이 뜨면서 정상적으로 설정이 된 것을 확인할 수 있습니다. 하단 오른쪽 부분에 Apply를 누르고 Ok를 누릅니다.

이제 다시 한번 실행을 하게 되면 정상적으로 출력이 되는 것을 확인을 할 수 있습니다. 혹시나 파이썬 Base Interpreter에서 아무런 버전도 선택이 되지 않는다면 파이썬을 따로 설치하는 것을 추천해드립니다.

 

파이참(PyCharm IDE) : 다운로드 [#]

 

다운로드 PyCharm: JetBrains가 만든 전문 개발자용 Python IDE

 

www.jetbrains.com

파이썬(Python) : 다운로드 [#]

 

Download Python

The official home of the Python Programming Language

www.python.org

그럼 도움이 되시길 바랍니다.

 

728x90